Results 1 to 2 of 2

Thread: spartan drive cable spins in collett

  1. #1
    Junior Member
    Join Date
    May 2012
    Posts
    1

    spartan drive cable spins in collett

    I'm new to this site and i have a few questions about my spartan. I bought my spartan last year and only ran the stock batteries, this year i bought a couple venom 3s 11.1v 20c lipos. Last year the boat ran without a problem, i also have the updated castle system. When i put the fully charged lipos in ,it ran like it was in training mode ,i then got it into race mode i think because i had no reverse, it took off pretty good ,but then slowed once . When i got it back the drive cable was loose in the collett and the motor was at about 100 degrees. I tried it again and it keeps loosening from the collett and spins. What i want to know is can i use thread locker lock tight to fix this .My other question is could the esc be cutting power because of these lipos, it doesn't seem to have the zip it should. I read 2s may be a better option for the spartan. Thanks for any help i can get.:

  2. #2
    Senior Member rcman's Avatar
    Join Date
    Nov 2011
    Location
    Hartland, Wisconsin
    Posts
    847
    I Well I know that Jeremy just uses 1 big 5 cell LiPo
    If nobody comes back from the future to stop you, how bad of a decision can it be?
    -Traxxas Rustler VXL
    -Axial SCX10 Jeep Wrangler

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •