Results 1 to 9 of 9

Thread: Puffed Zippy Lipo

  1. #1
    Moderator
    Join Date
    Oct 2010
    Location
    Louisiana
    Posts
    424

    Puffed Zippy Lipo

    I'm pretty sure you can tell which one is puffed. The other one is working fine. I charged it on NiMh to get the voltage up because Lipo mode wouldn't charge it due to low voltage. I'm sending it back to Hobbyking to exchange for a new one.

    100_0216.jpg100_0215.jpg
    2nd Place is the 1st Loser

    E Revo Mamba Monster 2200kv
    Slash 2WD Stock with Homemade Swaybars

    Youtube Account:
    [url]http://www.youtube.com/user/TheChris1696?feature=mhum[/url]

  2. #2
    RCN Moderator dizzyinzo's Avatar
    Join Date
    Oct 2010
    Location
    louisiana
    Posts
    421
    idk its up to you really but my venoms that i run in my baby e revo are puffed like that. i would just get a lipo sack if you charge them again. and dont charge them on the wrong setting but i think its because they arent ballanced
    [url=http://www.youtube.com/user/dizzyinzo?feature=mhum#p/a/u/0/u5ZEPGsD7wM]Check out my YouTube Channel : ill sub back if you sub me... CLICK ME [/url]

  3. #3
    Moderator
    Join Date
    Oct 2010
    Location
    Louisiana
    Posts
    424
    That's why I'm buying that passport ACDC charger that has a built in balancer.
    2nd Place is the 1st Loser

    E Revo Mamba Monster 2200kv
    Slash 2WD Stock with Homemade Swaybars

    Youtube Account:
    [url]http://www.youtube.com/user/TheChris1696?feature=mhum[/url]

  4. #4
    Senior Member batman's Avatar
    Join Date
    Oct 2010
    Location
    indiana
    Posts
    289
    check out thunderpower chargers they have a lipo revovery mode for lipos that are drained to far
    i have actually used that mode to bring back some little mp3 player batteries that did not want to take a charge

  5. #5
    scubaboy
    Guest
    Quote Originally Posted by TheChris1696 View Post
    I'm pretty sure you can tell which one is puffed. The other one is working fine. I charged it on NiMh to get the voltage up because Lipo mode wouldn't charge it due to low voltage. I'm sending it back to Hobbyking to exchange for a new one.

    100_0216.jpg100_0215.jpg
    maybee it you balanced the lipos it would help.

  6. #6
    Moderator
    Join Date
    Oct 2010
    Location
    Louisiana
    Posts
    424
    That's what I was thinking.
    2nd Place is the 1st Loser

    E Revo Mamba Monster 2200kv
    Slash 2WD Stock with Homemade Swaybars

    Youtube Account:
    [url]http://www.youtube.com/user/TheChris1696?feature=mhum[/url]

  7. #7
    Senior Member
    Join Date
    May 2011
    Posts
    83
    do NOT use that battery again! it may explode or catch fire in your car

  8. #8
    Moderator
    Join Date
    Oct 2010
    Location
    Louisiana
    Posts
    424
    Quote Originally Posted by MERVlife View Post
    do NOT use that battery again! it may explode or catch fire in your car
    I sent it back to Hobbyking and hopefully they will replace both of them. They had bad unbalanced cells!
    2nd Place is the 1st Loser

    E Revo Mamba Monster 2200kv
    Slash 2WD Stock with Homemade Swaybars

    Youtube Account:
    [url]http://www.youtube.com/user/TheChris1696?feature=mhum[/url]

  9. #9
    Member Spektrum's Avatar
    Join Date
    May 2011
    Location
    Arizona
    Posts
    25
    That same thing happened on one of my thunder power batteries, and it could not hold a charge.
    Factory Team B44, Mamba Max Pro, 4600kV Neu-Motor, Spektrum dx3e, Savox digital servo, Reedy Li-Po 60c saddle pack .

    Factory Team SC10, Spectrum digital servo, Leopard speed control and 17.5 motor, Venom Li-Po 20c 3800mah, Associated 27mhz radio.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •