Results 1 to 9 of 9
Like Tree1Likes
  • 1 Post By ian2

Thread: I cant get my ESC on a specific mode

  1. #1
    Member
    Join Date
    May 2011
    Location
    Menomonee Falls, WI
    Posts
    38

    I cant get my ESC on a specific mode

    I have a traxxas velinion vxl-3s ESC and i cant get it into a specific mode(training, race, and sport). I do the button hold combinations as instructed but i just cant seem to get the green light. i didnt really have this problem with my xl-5. Is this a common problem?

  2. #2
    RCN Moderator dizzyinzo's Avatar
    Join Date
    Oct 2010
    Location
    louisiana
    Posts
    421
    i had an issue doing that.... my answer was a fully charged battery. i dont know if that will help you or not
    [url=http://www.youtube.com/user/dizzyinzo?feature=mhum#p/a/u/0/u5ZEPGsD7wM]Check out my YouTube Channel : ill sub back if you sub me... CLICK ME [/url]

  3. #3
    Senior Member ian2's Avatar
    Join Date
    Mar 2011
    Location
    michigan
    Posts
    209
    your button must be stuck down ? try putting a dot of shot oil in the button ? otherwise i ahve no idea
    erevofreak96 likes this.
    full throttle or else it must be broke but breaking it is just another reason to build it bigger and better than before!

  4. #4
    Senior Member batman's Avatar
    Join Date
    Oct 2010
    Location
    indiana
    Posts
    289
    what mode do you want?
    or are you trying to change battery type? if battery type start with unit off and hold button for 15-25 seconds

  5. #5
    RCN Staffer
    Join Date
    Mar 2011
    Location
    SE WI
    Posts
    190
    If you're trying to change profiles you won't see a green light except for when you first press the button. If you continue to hold it down you will see red, then red blinking once, twice, and thrice. You let go after the profile you want (1, 2, or 3).

    If you still can't get it stop by Hobbytown in Germantown tomorrow and I can help ya out.
    Volt Up. Gear Down.

    Team RCN - Subscribe - Youtube RC Nightmare

  6. #6
    Member
    Join Date
    May 2011
    Location
    Menomonee Falls, WI
    Posts
    38
    that is what i do i see the green hold for one blink red and then let off to get sport mode. it still works as the sport mode profile but the light remains red.

  7. #7
    Senior Member
    Join Date
    Oct 2010
    Posts
    198
    my buttons on those always used to get stuck, just push it alot over and over... sounds dumb lol but eventually it will come out

  8. #8
    RCN Staffer
    Join Date
    Mar 2011
    Location
    SE WI
    Posts
    190
    You are definitely getting it into sport mode no problem. The red light is telling you that LIPO cutoff is turned off. If you're running a lipo turn on the Transmitter and ESC, make sure throttle works! Now hold the button down for 10 seconds until you hear it make a noise. Now that light will be green meaning that LIPO cutoff is turn ON. To turn it off do the exact same thing.
    Volt Up. Gear Down.

    Team RCN - Subscribe - Youtube RC Nightmare

  9. #9
    Junior Member
    Join Date
    Apr 2013
    Posts
    29
    I think your battery was not fully charged that's why you are facing this problem first charge your battery then check it I think the problem was gone

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •