Results 1 to 5 of 5

Thread: motor problem

  1. #1
    Junior Member
    Join Date
    Nov 2011
    Location
    australia, nsw
    Posts
    11

    Post motor problem

    Does anyone know if a 17t stock brushed thundertiger motor would go good in a venom safari creeper or a axial scx10.

    1. would it burn out?

    2. would it have enough torqe to got threw the trails?

    thanks...

  2. #2
    Junior Member
    Join Date
    Nov 2011
    Location
    Edmonton Alberta
    Posts
    7
    1) yez it can. Why you Ask . Its a motor! They wear out! Or just burn out . There is no rhyme or reason.
    2) Yes it will. Use between a 14 and 16 tooth pinion or u risk overheating the esc and motor.

  3. #3
    Senior Member rcbeginner's Avatar
    Join Date
    Oct 2010
    Location
    San Bernardino Ca
    Posts
    451
    just get a 20 turn motor from Dynamite rc cheap and has more torque and it has a internal fan to keep it cool

  4. #4
    Junior Member
    Join Date
    Nov 2011
    Location
    australia, nsw
    Posts
    11
    thanks....
    whats the best set up for a safari creeper? ( motor, esc, tires,) for going threw the bush?

  5. #5
    Senior Member rcbeginner's Avatar
    Join Date
    Oct 2010
    Location
    San Bernardino Ca
    Posts
    451
    do you have it stock? i just looked at the specs and the stock setup is pretty nice. i guess if you want more with it you should run lipos on it if not already. tires you should get some new tires ill gve you a site on where to check for your own perference. and there is lots of sites for all your crawling needs ill put up a list. they are not links just copy and paste hope this was helpful
    tcscrawlers.com
    RCCrawler.com
    CKRCcrawlers.com
    RC4WD.com
    RCrockcrawling.com
    rcplanet.com

Similar Threads

  1. motor problem
    By tom revelly in forum Electric RC General Discussions
    Replies: 2
    Last Post: 11-24-2011, 07:10 PM
  2. problem needs solving
    By shnebo in forum Electric RC General Discussions
    Replies: 6
    Last Post: 07-14-2011, 01:07 AM
  3. Problem with blitz...
    By nol3n in forum HPI ShortCourse Trucks
    Replies: 6
    Last Post: 06-21-2011, 04:32 AM
  4. new integy motor problem
    By mossycrawlerscx10 in forum Electric RC General Discussions
    Replies: 8
    Last Post: 05-08-2011, 05:02 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •