Results 1 to 6 of 6

Thread: Time for me to do a facepalm!

  1. #1
    Senior Member
    Join Date
    Feb 2012
    Posts
    133

    Time for me to do a facepalm!

    The other day I was cleaning out my motor for my summit and I must have been in a hurry and grabbed the WD-40 instead of the motor cleaner since they both had their labels taken off. Now the engine moves the truck for 5 feet then dies! DANG!

  2. #2
    Senior Member suburban_hooligan's Avatar
    Join Date
    Jun 2011
    Location
    So Cal
    Posts
    197
    iv done the same thing. only it didn't cause any problems. hell i used to spray brushed motors out with WD-40 cause i was out of motor spray. it just made the motor shiny and slippery and a dirt/dust magnet.
    respect your elders. we've been around longer and done more stupid things than you, therefore we're smarter

  3. #3
    Senior Member
    Join Date
    Oct 2010
    Posts
    198
    oops. lol that sucks bro

  4. #4
    Senior Member
    Join Date
    Feb 2012
    Posts
    118
    Sucks bad i would say. I suggest trying to clean it out with the motor cleaner or maybe even try a non chlorinated break cleaner or something to decrease it. Not sure just what but getting it out should help.

  5. #5
    Senior Member
    Join Date
    Feb 2012
    Posts
    133
    I used the engine break in technique. I put the motor in water for about and hour and ran it for that time! Do you think traxxas could send me a free one. Lifetime electronics warrantee!

  6. #6
    Senior Member
    Join Date
    Feb 2012
    Posts
    118
    Never happen. It is a 30 day warranty and you cannot get anything due to misuse or damage. Sorry to break the crap news. I just tied tut too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •