Results 1 to 7 of 7
Like Tree1Likes
  • 1 Post By rcman

Thread: Son crashed my truck!

  1. #1
    Junior Member cuffs50's Avatar
    Join Date
    Dec 2012
    Posts
    14

    Son crashed my truck!

    So my son crashed my redcat volcano epx pro full speed into a concrete pad which brought it to a dead stop. It had been acting funny since the second time I drove it. It would kind of jolt forward a few feet at a time then take off. After the crash there is absolutely no forward or reverse. My dad bought the same truck and his has the same kind of behavior (jolting). What could I possibly replace to fix the problem (and don't say the whole truck lol). I know they are "cheap" rc's but I didn't want to invest a lot if my son didn't like it. Thanks for any help.

    Sent from my EVO using Tapatalk 2

  2. #2
    Member
    Join Date
    Jan 2013
    Location
    if you even want to know you are a f****** stalker
    Posts
    49
    1 redcat sort of sucks 2 the way to fix it is to not buy a nother redcat buy a traxxas or maby losi but not redcat

  3. #3
    Senior Member rcman's Avatar
    Join Date
    Nov 2011
    Location
    Hartland, Wisconsin
    Posts
    847
    Quote Originally Posted by traxxaslova View Post
    1 redcat sort of sucks 2 the way to fix it is to not buy a nother redcat buy a traxxas or maby losi but not redcat
    dude, its so hard to read those comments, put periods or comas to show where the thought ends. thats like 4th grade english class stuff
    traxxaslova likes this.
    If nobody comes back from the future to stop you, how bad of a decision can it be?
    -Traxxas Rustler VXL
    -Axial SCX10 Jeep Wrangler

  4. #4
    Senior Member
    Join Date
    Jan 2012
    Location
    Vancouver island BC Canada
    Posts
    144
    sounds to me like an esc issue. You could try to upgrade if your budget will allow it, also look into your esc or remote settings. Might be a trimming or setting issue

  5. #5
    Junior Member cuffs50's Avatar
    Join Date
    Dec 2012
    Posts
    14
    Redcat sent me a brand new esc which I installed and that didn't solve it. The steering servo still works and responds to the transmitter properly but I get nothing from the motor. No throttle response at all.

    Sent from my EVO using Tapatalk 2

  6. #6
    Senior Member rcman's Avatar
    Join Date
    Nov 2011
    Location
    Hartland, Wisconsin
    Posts
    847
    motor couldl be fryed/burnt out
    If nobody comes back from the future to stop you, how bad of a decision can it be?
    -Traxxas Rustler VXL
    -Axial SCX10 Jeep Wrangler

  7. #7
    Junior Member cuffs50's Avatar
    Join Date
    Dec 2012
    Posts
    14
    Yeah honestly I think that's the only thing left it could be. What are the chances that one of the channels on the receiver go out?

    Sent from my EVO using Tapatalk 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •