Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: traxxas slash 4x4 problems

  1. #11
    Senior Member
    Join Date
    Jan 2012
    Location
    Racine, WI.
    Posts
    141
    I would guess that your slipper/dif is lose and that is why your not getting good power to the front. As for springs the stock dual rate springs are garbage. the open part is to soft and the tight parts and to hard, not sure how easy it is to find Losi parts in norway but thier springs are great and come in many strengths. You want 3.5 inch for the rear and 3 inch in the back. I run 3 pound springs in back and 1.5 pound springs in the rear and that works well for me I don't race though.

  2. #12
    Senior Member
    Join Date
    May 2012
    Location
    holland, michigan
    Posts
    266
    your wheel hubs might be stripped in the front and your shock oil is shot so you will need to replace that and get bigger springs if you want to make it last longer

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Traxxas slash 2wd
    By Hatchetman60 in forum Traxxas Short Course Trucks
    Replies: 11
    Last Post: 10-08-2012, 04:33 AM
  2. traxxas slash 4x4 problems
    By p0w3rslave in forum Traxxas Short Course Trucks
    Replies: 4
    Last Post: 06-19-2012, 12:40 AM
  3. traxxas slash
    By rctraxxas in forum Traxxas Short Course Trucks
    Replies: 10
    Last Post: 09-20-2011, 01:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •