Results 1 to 5 of 5

Thread: Traxxas f150 raptor brushless issues

  1. #1
    ManiacticRC
    Guest

    Angry Traxxas f150 raptor brushless issues

    Hey rcnightmare, i have a problem and i would really like to fix it asap, so i bought this Traxxas f150 raptor and within the first week i blew the brushes out of the titan 12 motor and broke the mounts that hold the brushes in place. so i went to my hobby shop and they said brushless was the way to go so i bought a ezrun hobby wing 35 a esc 9t brusless motor and fitted it to my car, now the car works fine but sometimes it will have full power and then all of a sudden it only has like 70 percent off its true power then it will sorta stop and go flat out agian and then it goes back to 70 percent, then after thats happened a few times the motor just stops working, after about 20 secounds it starts agian and sometimes i have to turn the truck on and off, the motor is really hot to touch burnt my fingers so i dont know ifs its overheating, im using a 5000mah 9.6 venom ni mh , so please help me thanks

  2. #2
    Senior Member
    Join Date
    Jan 2012
    Location
    Racine, WI.
    Posts
    141
    If your over heating I would say try gearing down a little and see if that helps, also check your gear mesh if its to tight you may be binding and that can cause heat also. If nothing else try taking it in to the hobby shop and see if they can help it could be that you just got a bad motor or ESC.

  3. #3
    ManiacticRC
    Guest

    Traxxas f 150 raptor

    Quote Originally Posted by Haphazzard View Post
    If your over heating I would say try gearing down a little and see if that helps, also check your gear mesh if its to tight you may be binding and that can cause heat also. If nothing else try taking it in to the hobby shop and see if they can help it could be that you just got a bad motor or ESC.
    Alright i think i got a bigger spur with the car so just chuck that on it ? also thanks so much for helping ill take the cover of and run it and see if its all tight in there. cheers agian

  4. #4
    ManiacticRC
    Guest
    One thing i have noticed is that when the motor stops working the red light on the esc begins to flash then when the motor starts working agian it stops flashing

  5. #5
    Senior Member
    Join Date
    May 2012
    Location
    holland, michigan
    Posts
    266
    gear down a little bit and you might need to program it
    i had that problem with mine
    but mine could only handle 8.4v so you might be running a to big of a battery

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •